This forum uses cookies
This forum makes use of cookies to store your login information if you are registered, and your last visit if you are not. Cookies are small text documents stored on your computer; the cookies set by this forum can only be used on this website and pose no security risk. Cookies on this forum also track the specific topics you have read and when you last read them. Please confirm whether you accept or reject these cookies being set.

A cookie will be stored in your browser regardless of choice to prevent you being asked this question again. You will be able to change your cookie settings at any time using the link in the footer.

<
[-]
Latest Threads
Greetings from Manchester
Last Post: Kapulot
Today 12:17 AM
» Replies: 2
» Views: 15
Brown & toilet paper like bits!
Last Post: Kapulot
Today 12:14 AM
» Replies: 2
» Views: 26
Lunar's new tank
Last Post: Colin Whitworth
Yesterday 10:38 PM
» Replies: 100
» Views: 1804
Operation Bankruptcy
Last Post: KevB
Yesterday 09:36 PM
» Replies: 462
» Views: 41500
Annie’s Tank - Bikini Bottom
Last Post: debiharry
Yesterday 09:26 PM
» Replies: 883
» Views: 39726
Wingnut55's Juwel Rio 450 LED
Last Post: Hanlou
Yesterday 09:09 PM
» Replies: 1783
» Views: 267425
Little project
Last Post: Mark_Wood
Yesterday 08:58 PM
» Replies: 33
» Views: 408
High nitrites during cycle
Last Post: DrHouse
Yesterday 08:54 PM
» Replies: 6
» Views: 45
Betta + tetra feeding.. How?
Last Post: Jen1981
Yesterday 08:35 PM
» Replies: 6
» Views: 63
Han's Shrimpy Scape!
Last Post: Hanlou
Yesterday 08:31 PM
» Replies: 29
» Views: 417
Marty's tank log
Last Post: Marty.h
Yesterday 06:58 PM
» Replies: 252
» Views: 5696
Going bigger
Last Post: piker
Yesterday 06:50 PM
» Replies: 67
» Views: 1397
Angelfish "experts" re sick Manacapuru
Last Post: Alex34
Yesterday 06:34 PM
» Replies: 11
» Views: 125
One of my danios is missing
Last Post: jacksdad
Yesterday 05:46 PM
» Replies: 7
» Views: 95
Wiggles tank
Last Post: Wiggles
Yesterday 05:18 PM
» Replies: 66
» Views: 1799

Still getting debris / particles in my water
#1
Morning all, any advice on this would be appreciated.  No matter how hard I try, I still seem to be keep getting debris in my water.  The attached video shows what I mean.  I have an external filter, and as you can see from the video, the spray bar is at one end, and the intake on the other side.  When I look closely, I can see some of the particles being picked up by the intake, but the water never seems to be completely clean

How are people getting crystal clean water?  I have an All Pond Solutions 1400EF, with bottom having 3 layer filter (thick, medium and fine), the second and third have bio-mass in them


Reply
Thanks given by:
#2
Welcome to the forum. Smile
If it were me, I would do two things.
One is to try to get the flow a bit faster, which would then mean the input to filter works a bit better, and the other is to raise the input (to the filter) slightly so it is nearer the level of the particles.
Failing that I would pop some Purigen in the filter, but I'd try the free option first..... Wink
If at first you don't succeed....
...get someone else to do it! Big Grin

Enjoy your fish, shrimps and snails!
Ian

All my posts are from a desktop.
Mobiles are way too complicated for me, although I do have one now. Wink
Reply
Thanks given by:
#3
(12-09-2019, 12:00 PM)plankton Wrote: Welcome to the forum. Smile
If it were me, I would do two things.
One is to try to get the flow a bit faster, which would then mean the input to filter works a bit better, and the other is to raise the input (to the filter) slightly so it is nearer the level of the particles.
Failing that I would pop some Purigen in the filter, but I'd try the free option first..... Wink
The flow is at max for that pump, there is no adjusting on the AllPondSolution 1400EF ... the spray bar, with the smaller holes probably slows it down a little.  Some of the particles are going past the input, and getting sucked in ... but it never seems to fully clear the water ... is that normal?
Reply
Thanks given by:
#4
What filter media did you get with the APS filter? I would have thought something like the Floss Pads they sell would catch this kind of debris. Or you could pick up something similar in your LFS.

As @plankton says though, you can't go wrong with Purigen, it's great stuff albeit higher priced than most other filter media.
311l 48x18x22

[Image: YhXwIjol.jpg]
Reply
Thanks given by:
#5
(12-09-2019, 01:52 PM)lunar jetman Wrote: What filter media did you get with the APS filter? I would have thought something like the Floss Pads they sell would catch this kind of debris. Or you could pick up something similar in your LFS.

As @plankton says though, you can't go wrong with Purigen, it's great stuff albeit higher priced than most other filter media.
I have a 3 layer filter in the bottom tray made up of coarse filter pad at the bottom, then medium filter pad in the middle, finished off with a fine filter like you mentioned ... it just never seems to get everything out of the water

What does Purigen do, is it a filter?
Reply
Thanks given by:
#6
Its a type of filter media

https://www.seachem.com/purigen.php

Reasonably priced on Amazon

https://www.amazon.co.uk/Seachem-Purigen...237&sr=8-1
311l 48x18x22

[Image: YhXwIjol.jpg]
Reply
Thanks given by:
#7
I would add a filter floss to the top tray of the filter as the last part of the filtration, any small particles should get trapped.
I would also raise your spray bar and point the flow towards the surface so that the flow breaks the surface water, this will help with oxygenation.

All the best
Stephen
Reply
Thanks given by:


Forum Jump:


Users browsing this thread: 1 Guest(s)